沈阳信息港

当前位置:

基于CDMA网络的煤矿瓦斯监控无线数据传

2019/04/25 来源:沈阳信息港

导读

煤矿瓦斯事故是煤矿安全生产中发生频率高、危害程度大的主要事故源。做好煤矿安全生产管理工作,解决煤矿瓦斯隐患是实现煤矿安全生产状态根本好转的关

煤矿瓦斯事故是煤矿安全生产中发生频率高、危害程度大的主要事故源。做好煤矿安全生产管理工作,解决煤矿瓦斯隐患是实现煤矿安全生产状态根本好转的关键一环,也是国家煤矿安全监察局当前部署的重点工作之一。实行统一的“煤矿安全监控系统”对煤矿安全生产的长治久安具有极其重要的意义。

随着CDMA络无线数据传输技术的日益成熟,通过基于CDMA提供的无线数据传输服务,可有效解决煤矿瓦斯监控系统的瓦斯收集数据传输难的问题。宁夏电信基于CDMA无线数据分组络实现无线数据传输服务,建设宁夏全区煤矿系统瓦斯监控平台,并且通过短信告警服务关与CDMA短信关系统对接,实现的短信告警服务功能。

概述

1.基本概念与原理

宁夏利用CDMA无线络,构建了VPDN虚拟专用拨号络,构成无线数据传输通道提供数据传输。

VPDN的具体实现是采取隧道技术,行将企业的数据封装在隧道中进行传输。隧道技术的基本进程是在源局域与公的接口处将数据(是OSI7层模型中的络层数据)作为负载封装在一种可以在公上传输的数据格式中,在目的局域与公的接口处将数据解封装,取出负载。被封装的数据包在互联上传递时所经过的逻辑路径被称为“隧道”。要使数据顺利地被封装、传送及解封装,通信协议是保证的核心。

VPDN主要是采用第二层隧道协议(L2TP),采取L2TP基于以下几点原因。

其一,对GRE(通用路由封装协议)及IPSec这些三层隧道协议,辨别用户将比较困难;由于在三层(IP层),一般只能通过IP 地址来辨别用户。对VPN来说,用户的地址是可以重复的,这样,三层隧道协议不适合辨别用户。

其二,L2TP 是二层(链路层)的隧道协议,是作为PPP 的扩展提出来的。PPP适合辨别不同的用户,比如拨号用户、采取专线直连的对端路由器等等,因为PPP 可以得到对端的用户名和更多用户信息。对于拨号用户接入这种情况来讲,需要辨别不同的VPN 用户,使用L2TP进行VPDN组建是理想的。

其三,采取L2TP隧道协议,只分配企业内部IP地址,而PPTP等第二层的隧道协议,要求有正式的IP地址,在拨入拨号服务器时,由拨号服务器提供,再二次拨入企业关时,由企业关分配内部地址。

其4,采取L2TP隧道协议的VPDN络,通讯运营商主要维护运营商和企业之间的2层隧道。不同企业之间的2层隧道是辨别开来的,相互独立的2层隧道将保证各企业VPDN的完全私有性和安全性。

2.络系统构成

VPDN服务主要由CDMA1x路由器、LAC和LNS(防火墙或cisco接入路由器如C2600 Series)、AAA和内部服务器构成。

CDMA1x路由器: 连接在远程络上的访问终端,是VPDN呼唤的发起者。

LAC: 是“第二层隧道协议(L2TP)访问集中器”,在CDMA1x分组中是PDSN节点。它是L2TP隧道的其中一个端点,也是LNS的对端。LAC处于LNS和Client的中间,负责转发双方的数据包。从LAC发往LNS的数据包需要封装到L2TP隧道中,而从LAC到Client的连接则使用CDMA1x无线分组传输技术。

LNS: 是“第二层隧道协议络服务器”。它是L2TP隧道的另一个端点,也是LAC的对端。它是PPP会话的逻辑终点,而PPP会话被LAC封装成隧道情势,是从Client端开始的。

AAA server:AAA是认证、授权和记帐的缩写。AAA服务器负责对Client的身份进行验证。

3.实现进程

远程无线CDMA1x路由器通过CDMA1x络连入造访地LAC。LAC服务器通过用户名或接入号码识别出该用户为VPDN用户后,就和用户的目的VPDN服务器(企业内部服务器)建立一条连接,这条连接称为隧道,然后将用户数据包封装成IP报文后从该隧道传送给VPDN服务器,VPDN服务器收到数据包并拆封后就可以读到真正有意义的报文了。具体流程如图1。

瓦斯数据无线传输络的实现

1.络建设的主要内容

瓦斯无线数据传输络重点解决各矿井瓦斯数据传输集中的困难,实现由散布在各市、县级的矿井节点汇聚到区级集中节点构成无线数据传输络。

煤矿瓦斯采集数据无线传输进程包括:煤矿瓦斯数据通过专用设备(搜集终端)进行搜集,搜集的数据包括矿井瓦斯浓度、温度、透风情况、风扇工作情况等。收集到的数据通过矿井监控络传输到井上系统计算机,安装在计算机上的协议转换软件进行数据格式和协议转换,转换后的数据通过接口(如RS232接口模块等)接到无线数据通讯终端,并完成数据在无线通信络上的数据传输。

2、无线数据传输络简图

煤炭瓦斯监控系统在CDMA络服务承载上主要有两个部分:CDMA无线数传部分和短信告警服务部分,如图2所示。

数字专线部份:租用2M光纤线路,与煤矿安全监察络组建的VPDN络相连,通过CDMA无线络完成自治区煤矿安全监察局与各煤矿之间的信息上传下达。

矿井数据采集线路及传输部分:煤矿将从井下收集各种安全数据汇总到煤矿传输终端,通过CDMA无线络传输至电信公司络中心PDSN装备,再通过2M专线传输到宁夏煤矿安全监察局监控中心。

3.矿井层面的无线传输络实行

(1)络规范

煤矿监测监控系统地面主机与现场实时数据收集机之间的数据传输,采用串行口接口方式;从现场数据收集机到上行各节点采取TCP/IP方式传输。

其体系结构为:实时数据搜集节点与现场接口层节点之间监测,构成分布式体系结构,络拓扑结构采取总线形及星形。

访问方式采取主从方式。主从方式就是一个高级别的节点控制所有的信号传输,顺序和时间。除非主节点要求,其他节点不能通信。

实时数据收集通讯规范包括:采取RS-232串行数据接口标准;接口支持MODEM通讯方式,支持主动拨号和被动拨号方式;支持CDMA方式数据传输,自动适应厂家数据通过CDMA方式透明数据传输。

(2)瓦斯监控收集装备连接

在煤矿矿井现场,井上、下数据搜集通过Super KJ系列井下数据采集设备进行搜集,其中收集设备搜集到的数据通过协议转换器进行协议转换,转换后的数据通过串口(RS232)接到RW2000-DTU(CDMA无线路由器),RW2000-DTU完成数据在CDMA无线数据分组络中透明的数据传输,如图3所示。

瓦斯数据无线传输络配置方法

1.络设备连接示意图

瓦斯数据无线传输络依托CDMA无线数据分组络,建立基于L2TP协议VPDN方式的无线传输络接入,如图3所示。

其中,CDMA ROUTER与CDMA专认证服务器均采取的是成都中联信通科技有限公司生产的CDMA无线互联装备。

2.络分配说明

客户侧中心CISCO路由器、CDMA专认证服务器、防火墙在同一段172.15.241.0/24,特别注意CDMA专认证服务器的INTERFACE 1接口缺省路由指向防火墙172.15.241.1

运营商光纤的段为10.150.0.24/30,注意LNS CISCO 28路由器的缺省路由指向联通光纤端10.150.0.25

CDMA ROUTER WAN:为CDMA认证服务器配合LNS固定分配的IP:189.18.20.1/32,它是LNS的虚拟接口。

CDMA ROUTER LAN在段182.39.228.0/28,井下数据采集服务工作站的缺省路由指向CDMA ROUTER LAN。

S配置说明

Router#sh run

aaa new-model

aaa authentication login default local

aaa authentication ppp default group radius //认证方式为RADIUS

aaa accounting network default start-stop group radius //计费为RADIUS

aaa session-id common //以上aaa配置

ip dhcp-server 172.15.241.41 //IP地址交给RADIUS 172.15.241.41

vpdn enable

vpdn-group vpdn

! Default L2TP VPDN group

accept-dialin

protocol l2tp

virtual-template 1 // 指定到虚接口

lcp renegotiation always // 总是重新协商

l2tp tunnel password 0 Jt*3bk //有关l2TP VPDN的配置

interface FastEthernet0/0

description "link to local area"

ip address 172.15.241.40 255.255.255.0

duplex auto

speed auto // 络接口F0/0配置

interface FastEthernet0/1

description link-to-Unicom

ip address 10.150.0.26 255.255.255.252

ip mtu 800 // 为防止L2TP包过大设置该值

duplex auto

speed auto //络接口F0/1配置

interface Virtual-Template1 // 虚接口配置

ip unnumbered FastEthernet0/0

peer default ip address dhcp //地址方式为RADIUS分配

compress mppc //重要,MPPC协议支持

ppp authentication chap pap //认证口令方式

ip classless

ip route 0.0.0.0 0.0.0.0 10.150.0.25 //LNS路由器缺省指向运营商光纤端

ip route 182.39.7.115 255.255.255.255 172.15.241.1

ip route 182.39.7.136 255.255.255.255 172.15.241.1

ip route 182.39.11.4 255.255.255.255 172.15.241.1

ip route 182.39.161.3 255.255.255.255 172.15.241.1

ip route 182.39.228.0 255.255.255.240 189.18.20.1 //精确路由

radius-server host 172.15.241.41 auth-port 1812 acct-port 1813 key cdmacdma

radius-server retransmit 0

以上是有关RADIUS的主要配置。host 172.15.241.41表示RADIUS的IP地址; auth-port 1812表示认证端口;acct-port 1813表示计费端口;key cdmacdma 表示LNS和RADIUS之间的认证口令,也是CDMA认证服务器要用到的LNS密码。

4、CDMA认证服务器配置说明

本运用中采取的CDMA认证服务器是成都中联信通科技有限公司的CDMA专用认证服务器,具体配置部份以下。

接口1配置:在“端口配置”的“Interface 1地址”菜单里配置IP地址为172.15.241.41,子掩码为255.255.255.0,默认关为172.15.241.1;

Radius服务配置:LNS密码主要保证和LNS相互协商的密码,这里是cdmacdma。和CISCO路由器保持一致;认证端口缺省为1812;计费端口缺省为1813。

RADIUS用户配置:主要有IMSI、用户名、密码及IP地址四个部份构成。其中IMSI 是全球移动络中的客户识别码,也是CDMA认证服务器无线身份辨认的ID;用户名及密码为每一个无线终端分配一个登录名及密码,并且要求用户名;IP地址为每个无线终端分配的IP地址,该地址是由服务端中心强迫分配下去的,无线终端无权协商或要求。

男人神经衰弱吃什么药
月经颜色淡怎么调理
三岁小孩睡觉出汗是怎么回事
标签